Visit Captain Sim web site  
  Welcome, Guest. Please Login or Register

 

Page Index Toggle Pages: 1 Send TopicPrint
V/S not working (Read 1170 times)
R73777
Full Member
*
Offline



Posts: 30
Joined: May 22nd, 2021
V/S not working
Dec 10th, 2023 at 2:49pm
Print Post  
What’s going on with the V/S it’s blank. Is there a fix?
  
Back to top
 
IP Logged
 
JimLabit
New Member
Offline



Posts: 3
Joined: Jul 8th, 2022
Re: V/S not working
Reply #1 - Dec 10th, 2023 at 5:59pm
Print Post  
Same problem here.  I had to reload MSFS 2020 because of program crashes.  After reloading it and re-adding Capt Sim's 777, the vertical speed is inop.  I am very familiar with MS2020, flying it since 2020.  This 777 add-on has been my very best airliner to fly.  I can't use it now because of the vertical speed flaw.  I have already made a post about this but got no response.  If you can find the problem, would appreciate being informed of it.  Good luck.
  
Back to top
 
IP Logged
 
johnkamlax
New Member
Offline



Posts: 1
Joined: Dec 11th, 2023
Re: V/S not working
Reply #2 - Dec 11th, 2023 at 4:50am
Print Post  
It's an easy fix, the only issue with my fix is the light doesn't turn on/off buthe V/S shows and you can adjust it. Here's the fix:

Go to: MSFS\Official\OneStore\asobo-vcockpits-instruments-b747-8\html_ui\Pages\VCockpit
\Instruments\Airliners\B747_8\VSpeed

Open B747_8_VSpeed.js with notepad.

You'll find the following:

class B747_8_VSpeed extends Boeing_FCU.VSpeed {
    get templateID() { return "B747_8_VSpeed"; }
    shouldBeVisible() {
        return SimVar.GetSimVarValue("L:AP_VS_ACTIVE", "number") === 1;
    }
}
registerInstrument("b747-8-vspeed-element", B747_8_VSpeed);
//# sourceMappingURL=B747_8_VSpeed.js.map

Copy the following:

class B747_8_VSpeed extends Boeing_FCU.VSpeed {
    get templateID() { return "B747_8_VSpeed"; }
}
registerInstrument("b747-8-vspeed-element", B747_8_VSpeed);
//# sourceMappingURL=B747_8_VSpeed.js.map

Save it and it'll work. Make sure to make a copy of the original in case you screw up and maybe someone else can look into the missing light.
  
Back to top
 
IP Logged
 
JimLabit
New Member
Offline



Posts: 3
Joined: Jul 8th, 2022
Re: V/S not working
Reply #3 - Dec 11th, 2023 at 8:19pm
Print Post  
Thank you johnkamlax.  At least it is usable now.  I pretend I have a defective bulb in the VS button.  LOL
  
Back to top
 
IP Logged
 
CAPIFUENZA
New Member
Offline



Posts: 2
Joined: Dec 11th, 2023
Re: V/S not working
Reply #4 - Dec 11th, 2023 at 9:45pm
Print Post  
Hello, do you think Captain Sim will make an update that corrects that V/S error?
The solution that John kindly provided is an alternative but I prefer to wait for MSFS2020 to fix the problem that occurred in the last update that deteriorated the V/S of the B777-200.
Thank you
  
Back to top
 
IP Logged
 
K2rockall
New Member
Offline



Posts: 1
Joined: Dec 14th, 2023
Re: V/S not working
Reply #5 - Dec 14th, 2023 at 9:33am
Print Post  
johnkamlax wrote on Dec 11th, 2023 at 4:50am:
Go to: MSFS\Official\OneStore\asobo-vcockpits-instruments-b747-8\html_ui\Pages\VCockpit

\Instruments\Airliners\B747_8\VSpeed


Where do I find that in the Steam Store version of Microsoft Flight Simulator? I don't have that file directory. I'd like to make this fix work as I also have the v/s problem now following SU14
  
Back to top
 
IP Logged
 
ozkanuk
Full Member
*
Offline



Posts: 7
Joined: Apr 24th, 2024
Re: V/S not working
Reply #6 - May 8th, 2024 at 2:18pm
Print Post  
B777-300ER on XBOX S Platform.

*V/S is not working.

*A/T can be armed/disarmed but A/T button is not working! Angry
  
Back to top
 
IP Logged
 
Page Index Toggle Pages: 1
Send TopicPrint
 
  « Board Index ‹ Board  ^Top